Can CleanUp! be used with Netscape 4.x, 6.x or 7.x or Mozilla 1.x?

Yes. Support for Netscape 7.x, as well as Mozilla 0.x and 1.x, was one of the new features added in CleanUp! 4.0. If you are using one of these browsers, then be sure to use CleanUp! 4.0 or later.

Similarly, support for Netscape Communicator 6.x was one of the major new features in CleanUp! 3.0 and support for Netscape Communicator 4.x was one of the major new features in CleanUp! 2.0. These older browsers are still supported by the latest version of CleanUp!, so it is recommended that you use the latest version available from the download page.

See also How can I tell which version of CleanUp! I am running?